Importer - Email & EHF - Process approve (Invoice approval)
Incident Report for Compello AS
Resolved
This incident has been resolved.
Posted Nov 01, 2019 - 14:05 CET
Investigating
Dear Customer,

We are investigating a potential problem and has temporarily stopped our services. We are sorry the inconvenience.

Best regards,
Compello Customer Service
Posted Nov 01, 2019 - 08:48 CET
This incident affected: PROCESS (PROCESS - Legacy PDF Collector).